OAG - Issues with Schedules following planned maintenance on 01June2025 – Incident details

Issues with Schedules following planned maintenance on 01June2025

Resolved
Major outage
Started 21 days agoLasted 1 day

Affected

Flight Info Direct

Major outage from 10:12 PM to 4:26 PM, Degraded performance from 4:26 PM to 8:11 AM

Flight Info API

Major outage from 10:12 PM to 4:26 PM, Degraded performance from 4:26 PM to 8:11 AM

Flight Info Alerts

Major outage from 10:12 PM to 4:26 PM, Degraded performance from 4:26 PM to 8:11 AM

Schedules Dynamic

Major outage from 10:12 PM to 4:26 PM, Degraded performance from 4:26 PM to 8:11 AM

Schedules SSIM File

Major outage from 10:12 PM to 12:22 PM, Degraded performance from 12:22 PM to 8:11 AM

Schedules WDF File

Major outage from 10:12 PM to 12:22 PM, Degraded performance from 12:22 PM to 8:11 AM

Updates
  • Resolved
    Resolved

    Recovery work is now complete for the incident impacting Flight Schedules, following the planned maintenance on 1st June.

    Current status on impacted services is as follows.

    • Delayed SSIM and WDF deliveries – All SSIM and WDF files from June 1st and 2nd have been delivered. All file deliveries for today are either completed or underway and our delivery cycle has returned to its normal cycle.

    • Schedules Dynamic is fully operational and up to date.

    • Flight Info Alerts, Direct and API schedules is fully operational and up to date.

    This incident is now fully resolved and OAG will be producing an RCA report, available on request.

    OAG apologises unreservedly for this significant outage and the disruption caused.

     

    For questions and concerns, please contact support@oag.com

  • Update
    Update
    Recovery work is ongoing for the incident impacting Flight Schedules, following the planned maintenance on 1_st_ June. We are continuing to work through recovery, with queued Schedules updates since 09:30 on 1_st_ June being processed into our systems. However, we continue to see the following impacts at this time. * Delayed SSIM and WDF deliveries – Processing is underway to create undelivered files from 1_st_ and 2_nd_ June. * Schedules updates are being processed through Schedules Dynamic. * Flight Info Alerts, Direct and API schedules are being updated as we process the backlog of schedules updates. Our technical teams are working on resolving these issues with urgency and we will provide our next update at 0900 (GMT +1) on 3_rd_ June. OAG apologises for any inconvenience and disruption caused. For questions and concerns, please contact [support@oag.com](mailto:support@oag.com)"
  • Monitoring
    Monitoring

    Recovery work is ongoing for the incident impacting Flight Schedules, following the planned maintenance on 1st June. We are continuing to work through recovery, but continue to see the following impacts at this time.

    • Delayed SSIM and WDF deliveries – Processing is underway to create undelivered files from 1st and 2nd June.

    • Schedules updates will be delayed until further notice through Schedules Dynamic and Flight Info Alerts

    • Flight Info Direct schedules daily refresh will be delayed

    Our technical teams are working on resolving these issues with urgency and we will provide our next update in 3 hours.

    OAG apologises for any inconvenience and disruption caused.

     

    For questions and concerns, please contact support@oag.com

  • Identified
    Identified

    OAG have identified the root cause of the ongoing incident with Flight Schedules, following the planned maintenance on 1st June. We are now working through recovery processes, but continue to see the following impacts at this time.

    • Delayed SSIM and WDF deliveries

    • Schedules updates will be delayed until further notice through Schedules Dynamic and Flight Info Alerts

    • Flight Info Direct schedules daily refresh will be delayed

    Our technical teams are working on resolving these issues with urgency and we will provide our next update in 3 hours.

    OAG apologises for any inconvenience and disruption caused.

     

    For questions and concerns, please contact support@oag.com

  • Investigating
    Investigating

    Following our planned maintenance today (1st June), OAG has unfortunately experienced some continued issues affecting our schedule data.

     

    While we are making every effort to resolve these issues as quickly as possible, we may continue to experience issues in the following areas:

    • Delayed SSIM and WDF deliveries

    • Schedules updates will be delayed until further notice through Schedules Dynamic and Flight Info Alerts

    • Flight Info Direct schedules daily refresh will be delayed

      Our technical teams are working on resolving these issues with urgency and we will provide further updates at 0900 GMT +1 on 2nd June.

    OAG apologises for any inconvenience and disruption caused.

     

    For questions and concerns, please contact support@oag.com