Flight Info Alert delivery

Resolved
Degraded performance
Started 4 months ago Lasted about 10 hours

Affected

Flight Info Alerts
Updates
  • Resolved
    Resolved

    We are pleased to announce that subsequent to Microsoft's update at approximately 08:43 GMT, we increased our resources to effectively manage the backlog resulting from the outage. Events are currently being distributed to customers' Event Hubs as anticipated. While there may be some latency during the distribution process, we anticipate the service to resume to normalcy shortly.

  • Monitoring
    Update

    At 08:53, OAG observed a stabilised service from Microsoft. Subsequently, we increased our resource levels, and the current progress indicates that we are successfully clearing the backlog at an approximate rate of 120 - 150k messages per minute.

    With this increased efficiency, we anticipate a swift resolution and foresee catching up on the backlog in the near term. We are monitoring the situation to ensure continued stability and optimal performance.

  • Monitoring
    Update

    Microsoft are still in the midst of mitigating the issue and have advised that the scale-out and load balancing operations are progressing well, and success rates have significantly increased in the past 30 minutes. They will continue to monitor progression and provide an update as events warrant.

  • Monitoring
    Monitoring

    Microsoft are investigating an issue within their infrastructure which is affecting our ability to deliver alerts to customer event hubs . We are continuing to monitor and explore alternate mitigations.